$re = '/(?<==)[^,\[\]]+(?=,)/m';
$str = '{date=Tue Mar 30 00:00:00 BST 2021, minDate=Mon Mar 29 00:00:00 BST 2021, holidays=[], maxDate=Mon Jul 05 05:00:00 BST 2027}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);