import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*) \\(\\1\\)\\.txt";
final String string = "aaaa (aaaa).txt\n\n"
+ "should become\n\n"
+ "aaaa.txt\n\n"
+ "and\n\n"
+ "bbb (bb) (bbb (bb)).txt\n\n"
+ "should become\n\n"
+ "bbb (bb).txt\n";
final String subst = "$1.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}