import re
regex = re.compile(r"^(.*) \(\1\)\.txt", flags=re.MULTILINE)
test_str = ("aaaa (aaaa).txt\n\n"
"should become\n\n"
"aaaa.txt\n\n"
"and\n\n"
"bbb (bb) (bbb (bb)).txt\n\n"
"should become\n\n"
"bbb (bb).txt\n")
subst = "$1.txt"
result = regex.sub(subst, test_str)
if result:
print(result)