$re = '/^(.*) \(\1\)\.txt/m';
$str = 'aaaa (aaaa).txt
should become
aaaa.txt
and
bbb (bb) (bbb (bb)).txt
should become
bbb (bb).txt
';
$subst = "$1.txt";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;