const regex = /^(.*) \(\1\)\.txt/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*) \\(\\1\\)\\.txt', 'gm')
const str = `aaaa (aaaa).txt
should become
aaaa.txt
and
bbb (bb) (bbb (bb)).txt
should become
bbb (bb).txt
`;
const subst = `$1.txt`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);