const regex = /B[lr]?il?aul?[td]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('B[lr]?il?aul?[td]', 'gm')
const str = `Healer's Briault renamed to Healer's Bliaut
Cleric's Briault renamed to Cleric's Bliaut
Hlr. Briault +1 renamed to Hlr. Bliaut +1
Clr. Briault +1 renamed to Clr. Bliaut +1
Orison Bliaud renamed to Orison Bliaut
Orison Bliaud +1 renamed to Orison Bliaut +1
Orison Bliaud +2 renamed to Orison Bliaut +2
Clr. Briault +2 renamed to Clr. Bliaut +2
Ebers Bliaud renamed to Ebers Bliaut
Ebers Bliaud +1 renamed to Ebers Bliaut +1
Gende. Bilaut +1 renamed to Gende. Bliaut +1
Piety Briault renamed to Piety Bliaut
Piety Briault +1 renamed to Piety Bliaut +1
Piety Briault +2 renamed to Piety Bliaut +2
Piety Briault +3 renamed to Piety Bliaut +3
Theo. Briault renamed to Theo. Bliaut
Theo. Briault +1 renamed to Theo. Bliaut +1
Theo. Briault +2 renamed to Theo. Bliaut +2
Theo. Briault +3 renamed to Theo. Bliaut +3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}