import re
regex = re.compile(r"B[lr]?il?aul?[td]", flags=re.MULTILINE)
test_str = ("Healer's Briault renamed to Healer's Bliaut\n"
"Cleric's Briault renamed to Cleric's Bliaut\n"
"Hlr. Briault +1 renamed to Hlr. Bliaut +1\n"
"Clr. Briault +1 renamed to Clr. Bliaut +1\n"
"Orison Bliaud renamed to Orison Bliaut\n"
"Orison Bliaud +1 renamed to Orison Bliaut +1\n"
"Orison Bliaud +2 renamed to Orison Bliaut +2\n"
"Clr. Briault +2 renamed to Clr. Bliaut +2\n"
"Ebers Bliaud renamed to Ebers Bliaut\n"
"Ebers Bliaud +1 renamed to Ebers Bliaut +1\n"
"Gende. Bilaut +1 renamed to Gende. Bliaut +1\n"
"Piety Briault renamed to Piety Bliaut\n"
"Piety Briault +1 renamed to Piety Bliaut +1\n"
"Piety Briault +2 renamed to Piety Bliaut +2\n"
"Piety Briault +3 renamed to Piety Bliaut +3\n"
"Theo. Briault renamed to Theo. Bliaut\n"
"Theo. Briault +1 renamed to Theo. Bliaut +1\n"
"Theo. Briault +2 renamed to Theo. Bliaut +2\n"
"Theo. Briault +3 renamed to Theo. Bliaut +3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")