using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ciao\/(.*\/)+?qu(.*?)nt(.*?)\.txt";
string input = @"ciao/a/tutt3i/quantiuosad.txt
ciao/a/quanti.txt
ciao/a/quantia.txt
quanti.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}