package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ciao\/(.*\/)+?qu(.*?)nt(.*?)\.txt`)
var str = `ciao/a/tutt3i/quantiuosad.txt
ciao/a/quanti.txt
ciao/a/quantia.txt
quanti.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}