import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ciao\\/(.*\\/)+?qu(.*?)nt(.*?)\\.txt";
final String string = "ciao/a/tutt3i/quantiuosad.txt\n"
+ "ciao/a/quanti.txt\n"
+ "ciao/a/quantia.txt\n\n"
+ "quanti.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}