import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^/\\*\\*(?:\\R\\h+\\*)*\\R\\h*\\*\\h*@mapping\\(|\\G(?!^)),?\\h*([^\\s=]+)=([^\\s,=()]+)";
final String string = "/**\n"
+ " * @mapping(table='example')\n"
+ " */\n"
+ "class Example {\n\n\n"
+ "/**\n"
+ " * @mapping(table='example', else=something,...)\n"
+ " */\n"
+ "class Example {";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}