re = /(?:^\/\*\*(?:\R\h+\*)*\R\h*\*\h*@mapping\(|\G(?!^)),?\h*([^\s=]+)=([^\s,=()]+)/m
str = '/**
* @mapping(table=\'example\')
*/
class Example {
/**
* @mapping(table=\'example\', else=something,...)
*/
class Example {'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end