$re = '`(?:^/\*\*(?:\R\h+\*)*\R\h*\*\h*@mapping\(|\G(?!^)),?\h*([^\s=]+)=([^\s,=()]+)`m';
$str = '/**
* @mapping(table=\'example\')
*/
class Example {
/**
* @mapping(table=\'example\', else=something,...)
*/
class Example {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);