const regex = new RegExp('(?:^/\\*\\*(?:\\R\\h+\\*)*\\R\\h*\\*\\h*@mapping\\(|\\G(?!^)),?\\h*([^\\s=]+)=([^\\s,=()]+)', 'gm')
const str = `/**
* @mapping(table='example')
*/
class Example {
/**
* @mapping(table='example', else=something,...)
*/
class Example {`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}