$re = '/(?:\p{L}*(\p{L})\P{L}+(?=\1))+\p{L}+/mi';
$str = 'word !dark,123 king... glow__we 3end hello bye low3 ?wing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);