import re
regex = re.compile(r"(?:\p{L}*(\p{L})\P{L}+(?=\1))+\p{L}+", flags=re.MULTILINE | re.IGNORECASE)
test_str = "word !dark,123 king... glow__we 3end hello bye low3 ?wing"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")