re = /(?:\p{L}*(\p{L})\P{L}+(?=\1))+\p{L}+/mi
str = 'word !dark,123 king... glow__we 3end hello bye low3 ?wing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end