#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?=(?:.*?[a-z]){5})(?=(?:.*?\d){4}).*"
Local $sString = "ffffasfsaf242343242" & @CRLF & _
"2vv4fj222" & @CRLF & _
"555553jjjjjj" & @CRLF & _
"fdsfafadsfdf" & @CRLF & _
"234234324232" & @CRLF & _
"4444fasdfasf" & @CRLF & _
"3j3j3j3j3j3" & @CRLF & _
"11111jjjjjnnn" & @CRLF & _
"ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")