import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:.*?[a-z]){5})(?=(?:.*?\\d){4}).*";
final String string = "ffffasfsaf242343242\n"
+ "2vv4fj222\n"
+ "555553jjjjjj\n"
+ "fdsfafadsfdf\n"
+ "234234324232\n"
+ "4444fasdfasf\n"
+ "3j3j3j3j3j3\n"
+ "11111jjjjjnnn\n"
+ "ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}