re = /^(?=(?:.*?[a-z]){5})(?=(?:.*?\d){4}).*/im
str = 'ffffasfsaf242343242
2vv4fj222
555553jjjjjj
fdsfafadsfdf
234234324232
4444fasdfasf
3j3j3j3j3j3
11111jjjjjnnn
ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end