use strict;
my $str = '1;John;Doe;45
2;jaja;dada;2';
my $regex = qr/(;)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";