import Foundation
let pattern = #"(;)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1;John;Doe;45
2;jaja;dada;2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)