# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([; ])/\n/g;t' <<< "1;John;Doe;45 2;jaja;dada;23"