#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([; ])"
Local $sString = "1;John;Doe;45 2;jaja;dada;23"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)