const regex = /([; ])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([; ])', 'g')
const str = `1;John;Doe;45 2;jaja;dada;23`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);