import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\\!\\-\\@\\.\\_\\*\\$\\#\\%\\^\\&\\(\\)\\~\\`\\<\\>\\/\\?\\\\\\|\\{\\}\\[\\]\\;\\:\\'\\\"\\,\\+])";
final String string = "aA1!\n"
+ "A1!a\n"
+ "1!aA\n"
+ "!aA1\n"
+ "aa1!\n"
+ "AA1!\n"
+ "aA!!\n"
+ "aA11\n"
+ "abcd\n"
+ "ABCD\n"
+ "1111\n"
+ "!!!!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}