use strict;
my $str = 'aA1!
A1!a
1!aA
!aA1
aa1!
AA1!
aA!!
aA11
abcd
ABCD
1111
!!!!';
my $regex = qr/^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!\-\@\.\_\*\$\#\%\^\&\(\)\~\`\<\>\/\?\\\|\{\}\[\]\;\:\'\"\,\+])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}