$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!\-\@\.\_\*\$\#\%\^\&\(\)\~\`\<\>\/\?\\\\\|\{\}\[\]\;\:\'\"\,\+])/m';
$str = 'aA1!
A1!a
1!aA
!aA1
aa1!
AA1!
aA!!
aA11
abcd
ABCD
1111
!!!!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);