const regex = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!\-\@\.\_\*\$\#\%\^\&\(\)\~\`\<\>\/\?\\\|\{\}\[\]\;\:\'\"\,\+])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\\!\\-\\@\\.\\_\\*\\$\\#\\%\\^\\&\\(\\)\\~\\`\\<\\>\\\/\\?\\\\\\|\\{\\}\\[\\]\\;\\:\\\'\\"\\,\\+])', 'gm')
const str = `aA1!
A1!a
1!aA
!aA1
aa1!
AA1!
aA!!
aA11
abcd
ABCD
1111
!!!!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}