import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$ABC(?!02$)[0-9]+$";
final String string = "$ABC01\n"
+ "$ABC02\n"
+ "$ABC03\n"
+ "$ABC04\n"
+ "$ABC05\n"
+ "$ABC0210";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}