import re
regex = re.compile(r"^\$ABC(?!02$)[0-9]+$", flags=re.MULTILINE)
test_str = ("$ABC01\n"
"$ABC02\n"
"$ABC03\n"
"$ABC04\n"
"$ABC05\n"
"$ABC0210")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")