$re = '/^\$ABC(?!02$)[0-9]+$/m';
$str = '$ABC01
$ABC02
$ABC03
$ABC04
$ABC05
$ABC0210';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);