#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!(?=[a-f\d]{24}$)(\d+[a-f]|[a-f]+\d)).+"
Local $sString = "112345679065574883030833" & @CRLF & _
"FFFFFFFFFFFFFFFFFFFFFFFF" & @CRLF & _
"45cbc4a0e4123f6920000002" & @CRLF & _
"112345679065574883030833" & @CRLF & _
"James Bond"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")