using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?=[a-f\d]{24}$)(\d+[a-f]|[a-f]+\d)).+";
string input = @"112345679065574883030833
FFFFFFFFFFFFFFFFFFFFFFFF
45cbc4a0e4123f6920000002
112345679065574883030833
James Bond";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}