import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?=[a-f\\d]{24}$)(\\d+[a-f]|[a-f]+\\d)).+";
final String string = "112345679065574883030833\n"
+ "FFFFFFFFFFFFFFFFFFFFFFFF\n"
+ "45cbc4a0e4123f6920000002\n"
+ "112345679065574883030833\n"
+ "James Bond";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}