re = /^(?!(?=[a-f\d]{24}$)(\d+[a-f]|[a-f]+\d)).+/mi
str = '112345679065574883030833
FFFFFFFFFFFFFFFFFFFFFFFF
45cbc4a0e4123f6920000002
112345679065574883030833
James Bond'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end