#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[.+\])\s+([^[]+)"
Local $sString = "[12/18/2017 1:22:12 PM] LOG FILE STREAM STARTED - v2.1.6561.24062, BUILD 12/18/2017 1:22:04 PM" & @CRLF & _
"[12/18/2017 1:22:17 PM] Network Configuration Changed: Current status of all interfaces:" & @CRLF & _
" - Ethernet 2 is DOWN - self-assigned IP" & @CRLF & _
"[12/18/2017 1:22:29 PM] Network Configuration Changed: Current status of all interfaces:" & @CRLF & _
" - Ethernet 2 is UP - IP address = 172.16.10.191"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")