import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[.+\\])\\s+([^[]+)";
final String string = "[12/18/2017 1:22:12 PM] LOG FILE STREAM STARTED - v2.1.6561.24062, BUILD 12/18/2017 1:22:04 PM\n"
+ "[12/18/2017 1:22:17 PM] Network Configuration Changed: Current status of all interfaces:\n"
+ " - Ethernet 2 is DOWN - self-assigned IP\n"
+ "[12/18/2017 1:22:29 PM] Network Configuration Changed: Current status of all interfaces:\n"
+ " - Ethernet 2 is UP - IP address = 172.16.10.191";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}