// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[.+\])\s+([^[]+)").unwrap();
let string = "[12/18/2017 1:22:12 PM] LOG FILE STREAM STARTED - v2.1.6561.24062, BUILD 12/18/2017 1:22:04 PM
[12/18/2017 1:22:17 PM] Network Configuration Changed: Current status of all interfaces:
- Ethernet 2 is DOWN - self-assigned IP
[12/18/2017 1:22:29 PM] Network Configuration Changed: Current status of all interfaces:
- Ethernet 2 is UP - IP address = 172.16.10.191";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}