const regex = /(\[.+\])\s+([^[]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[.+\\])\\s+([^[]+)', 'g')
const str = `[12/18/2017 1:22:12 PM] LOG FILE STREAM STARTED - v2.1.6561.24062, BUILD 12/18/2017 1:22:04 PM
[12/18/2017 1:22:17 PM] Network Configuration Changed: Current status of all interfaces:
- Ethernet 2 is DOWN - self-assigned IP
[12/18/2017 1:22:29 PM] Network Configuration Changed: Current status of all interfaces:
- Ethernet 2 is UP - IP address = 172.16.10.191`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}