#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0|(1(01*0)*1))*$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"110" & @CRLF & _
"111" & @CRLF & _
"1000" & @CRLF & _
"1001" & @CRLF & _
"1010" & @CRLF & _
"1011" & @CRLF & _
"1100" & @CRLF & _
"1101" & @CRLF & _
"1110" & @CRLF & _
"1111" & @CRLF & _
"10000" & @CRLF & _
"10001" & @CRLF & _
"10010" & @CRLF & _
"10011" & @CRLF & _
"10100" & @CRLF & _
"10101" & @CRLF & _
"10110" & @CRLF & _
"10111" & @CRLF & _
"11000" & @CRLF & _
"11001" & @CRLF & _
"11010" & @CRLF & _
"11011" & @CRLF & _
"11100" & @CRLF & _
"11101" & @CRLF & _
"11110" & @CRLF & _
"11111" & @CRLF & _
"100000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")