re = /^(0|(1(01*0)*1))*$/m
str = '0
1
10
11
100
101
110
111
1000
1001
1010
1011
1100
1101
1110
1111
10000
10001
10010
10011
10100
10101
10110
10111
11000
11001
11010
11011
11100
11101
11110
11111
100000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end