import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0|(1(01*0)*1))*$";
final String string = "0\n"
+ "1\n"
+ "10\n"
+ "11\n"
+ "100\n"
+ "101\n"
+ "110\n"
+ "111\n"
+ "1000\n"
+ "1001\n"
+ "1010\n"
+ "1011\n"
+ "1100\n"
+ "1101\n"
+ "1110\n"
+ "1111\n"
+ "10000\n"
+ "10001\n"
+ "10010\n"
+ "10011\n"
+ "10100\n"
+ "10101\n"
+ "10110\n"
+ "10111\n"
+ "11000\n"
+ "11001\n"
+ "11010\n"
+ "11011\n"
+ "11100\n"
+ "11101\n"
+ "11110\n"
+ "11111\n"
+ "100000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}