# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0|(1(01*0)*1))*$"
test_str = ("0\n"
"1\n"
"10\n"
"11\n"
"100\n"
"101\n"
"110\n"
"111\n"
"1000\n"
"1001\n"
"1010\n"
"1011\n"
"1100\n"
"1101\n"
"1110\n"
"1111\n"
"10000\n"
"10001\n"
"10010\n"
"10011\n"
"10100\n"
"10101\n"
"10110\n"
"10111\n"
"11000\n"
"11001\n"
"11010\n"
"11011\n"
"11100\n"
"11101\n"
"11110\n"
"11111\n"
"100000\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.