#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[dbo\]\.\[(?:LiveSales|CreditCards)\]"
Local $sString = "SELECT *" & @CRLF & _
"FROM [dbo].[LiveSales]" & @CRLF & _
"WHERE 1 = 1;" & @CRLF & _
"" & @CRLF & _
"SELECT *" & @CRLF & _
"FROM [dbo].[CreditCards]" & @CRLF & _
"WHERE 1 = 1;" & @CRLF & _
"" & @CRLF & _
"SELECT *" & @CRLF & _
"FROM [dbo].[OtherTable]" & @CRLF & _
"WHERE 1 = 1;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")