package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[dbo\]\.\[(?:LiveSales|CreditCards)\]`)
var str = `SELECT *
FROM [dbo].[LiveSales]
WHERE 1 = 1;
SELECT *
FROM [dbo].[CreditCards]
WHERE 1 = 1;
SELECT *
FROM [dbo].[OtherTable]
WHERE 1 = 1;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}