re = /\[dbo\]\.\[(?:LiveSales|CreditCards)\]/m
str = 'SELECT *
FROM [dbo].[LiveSales]
WHERE 1 = 1;
SELECT *
FROM [dbo].[CreditCards]
WHERE 1 = 1;
SELECT *
FROM [dbo].[OtherTable]
WHERE 1 = 1;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end