$re = '/\[dbo\]\.\[(?:LiveSales|CreditCards)\]/m';
$str = 'SELECT *
FROM [dbo].[LiveSales]
WHERE 1 = 1;
SELECT *
FROM [dbo].[CreditCards]
WHERE 1 = 1;
SELECT *
FROM [dbo].[OtherTable]
WHERE 1 = 1;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);