#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?<!\\)" & @CRLF & _
"(?<code_all>" & @CRLF & _
" (?<code_start>\`{1,})" & @CRLF & _
" (?<code_content>.+?)" & @CRLF & _
" (?<!`)" & @CRLF & _
" \g{code_start}" & @CRLF & _
" (?!`)" & @CRLF & _
")" & @CRLF & _
""
Local $sString = "foo `bar`"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")