using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)
(?<code_all>
(?<code_start>\`{1,})
(?<code_content>.+?)
(?<!`)
\g{code_start}
(?!`)
)
";
string input = @"foo `bar`";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}